coquisttjs

    0.1.1 • Public • Published

    CoquiSTTJs

    Coqui STT runtime transcript NodeJs client, including multithread (server) usage examples.

    What's Coqui STT?

    Coqui STT on github is an open-source Speech-To-Text engine, project fork of Mozilla DeepSpeech. Documentation for installation, usage, and training models are available on Coqui STT documentation.

    Now, you want to access Coqui STT speech to text transcription, from nodeJs. Coqui STT official native NodeJs API:

    Coqui STT run-time decoding, using NodeJs

    This project supplies to nodeJs developers a simple API interface on top of the Coqui STT native NodeJs binding. Here the current API javascript endpoints:

    • loadModel(modelFile, scorerFile)
    • transcriptBuffer(audioBuffer, model)
    • transcriptFile(audioFile, model)
    • freeModel(model)

    📦 Install

    Install Coqui STT engine, models, audio

    # Create a virtual environment
    $ python3 -m venv venv-stt
    $ source venv-stt/bin/activate
    
    # Install 🐸STT
    $ python3 -m pip install -U pip
    $ python3 -m pip install stt
    
    # Download 🐸's pre-trained English models
    $ curl -LO https://github.com/coqui-ai/STT/releases/download/v0.9.3/coqui-stt-0.9.3-models.pbmm
    $ curl -LO https://github.com/coqui-ai/STT/releases/download/v0.9.3/coqui-stt-0.9.3-models.scorer
    
    # Download some example audio files
    $ curl -LO https://github.com/coqui-ai/STT/releases/download/v0.9.3/audio-0.9.3.tar.gz
    $ tar -xvf audio-0.9.3.tar.gz
    
    # Transcribe an audio file
    $ stt --model coqui-stt-0.9.3-models.pbmm --scorer coqui-stt-0.9.3-models.scorer --audio audio/2830-3980-0043.wav

    Install CoquiSTTJs

    npm install coquisttjs

    🛠 Usage examples and tests

    Some usage examples and tests. Examples include:

    🎁 Bonus tracks

    • audioutils.js fast transcoding to PCM, using ffmpeg process (install ffmpeg before).

    🧶 Status

    • The project is in a very draft stage.
    • Current Coqui STT npm package solve the DeepSpeech issue. In facts current npm package deepspeech cause a crash using node version 16.0.0. BTW I had success using DeeSpeech npm package with Node version 14.16.1. See my project DeepSpeechJs.
    • Complete the high-level API interface. E.g. including metadata as parameters

    How to contribute

    If you like the project, please ⭐️ star this repository to show your support! 🙏

    Any contribute is welcome.

    • Discussions. Please open a new discussion (a publich chat on github) for any specific open topic, for a clarification, change request proposals, etc.
    • Issues Please submit issues for bugs, etc
    • e-mail You can contact me privately, via email.

    License

    MIT (c) Giorgio Robino


    top

    Install

    npm i coquisttjs

    DownloadsWeekly Downloads

    3

    Version

    0.1.1

    License

    MIT

    Unpacked Size

    61.2 kB

    Total Files

    26

    Last publish

    Collaborators

    • solyarisoftware