constraint-validation-buggyfill

2.0.0 • Public • Published

constraint-validation-buggyfill

npm version CI status

Prevents invalid form submission in browsers that improperly support the HTML forms spec (e.g. Safari v5 → 10). The first invalid element is focused after alerting the validation message. An alert is used due to poor browser support for reportValidity().

Setup

npm setup

To install from npm run:

npm install constraint-validation-buggyfill

Add this import to components with forms:

import 'constraint-validation-buggyfill'

CDN setup

To install from npm via the UNPKG CDN, add this script to pages with forms:

<script src="https://unpkg.com/constraint-validation-buggyfill"></script>

Support

See

Package Sidebar

Install

npm i constraint-validation-buggyfill

Weekly Downloads

63

Version

2.0.0

License

MIT

Unpacked Size

6.83 kB

Total Files

4

Last publish

Collaborators

  • jaydenseric