cliquiz-millionaire

1.0.0 • Public • Published

CLI Quiz

"Who wants to be a Millionaire? (JavaScript Edition)" Terminal Game


Requirements

For development, you will only need Node.js and a node global package, Yarn, installed in your environement.

Node

  • Node installation on Windows

    Just go on official Node.js website and download the installer. Also, be sure to have git available in your PATH, npm might need it (You can find git here).

  • Node installation on Ubuntu

    You can install nodejs and npm easily with apt install, just run the following commands.

    $ sudo apt install nodejs
    $ sudo apt install npm
    
  • Other Operating Systems

    You can find more information about the installation on the official Node.js website and the official NPM website.

If the installation was successful, you should be able to run the following command.

$ node --version
v17.5.0

$ npm --version
8.5.3

If you need to update npm, you can make it using npm!

$ npm install npm -g

Yarn installation

After installing node, this project will need yarn too, so just run the following command.

  $ npm install -g yarn

Install

$ git clone https://github.com/pycoder2000/CLI-Quiz.git
$ cd CLI-Quiz
$ yarn install

Running the project

$ node .

Package Sidebar

Install

npm i cliquiz-millionaire

Weekly Downloads

1

Version

1.0.0

License

ISC

Unpacked Size

24.2 kB

Total Files

5

Last publish

Collaborators

  • desaiparth