npm

Need private packages and team management tools?Check out npm Orgs. »

clarifai

2.9.1 • Public • Published

Clarifai logo

Clarifai API JavaScript Client

This is the official JavaScript client for interacting with our powerful recognition API. The Clarifai API offers image and video recognition as a service. Whether you have one image or billions, you are only steps away from using artificial intelligence to recognize your visual content.

Build Status npm version

Installation

Install the API client:

npm install clarifai

Basic Use

Firstly, generate your Clarifai API key on the API keys page. The client uses it for authentication.

Then, use the code below to create a Clarifai.App instance using which you interact with the client.

const Clarifai = require('clarifai');
 
const app = new Clarifai.App({
 apiKey: 'YOUR_API_KEY'
});

This will work in node.js and browsers via Browserify.

You can also use the SDK by adding this script to your HTML:

<script type="text/javascript" src="https://sdk.clarifai.com/js/clarifai-latest.js"></script>

Documentation

Dive right into code examples to get up and running as quickly as possible with our Quick Start.

Learn the basics — predicting the contents of an image, searching across a collection and creating your own models with our Guide.

Check out the JSDoc for a deeper reference.

Looking for a different client? We have many languages available with lots of documentation Technical Reference

React Native

You'll most likely encounter the error process.nextTick is not a function while using this library with React Native.

To solve this, add process.nextTick = setImmediate; as close to the top of your entrypoint as you can. See #20 for more info.

License

This project is licensed under the Apache 2.0 License - see the LICENSE file for details.

Keywords

none

install

npm i clarifai

Downloadsweekly downloads

1,795

version

2.9.1

license

Apache-2.0

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
Report a vulnerability