Neuron Powered Motorization
    Have ideas to improve npm?Join in the discussion! »

    casbin-mongoose-adapter

    2.2.3 • Public • Published

    Mongoose Adapter

    NPM version NPM download codebeat badge Build Status Coverage Status Gitter

    Mongoose Adapter is the Mongoose adapter for Node-Casbin. With this library, Node-Casbin can load policy from Mongoose supported database or save policy to it. It is originally developed by @ghaiklor from @elasticio.

    Based on Officially Supported Databases, The current supported database is MongoDB.

    Getting Started

    Install the package as dependency in your project:

    npm install --save casbin-mongoose-adapter casbin

    Note: casbin as peerDependencies!

    Require it in a place, where you are instantiating an enforcer (read more about enforcer here):

    const path = require('path');
    const { newEnforcer } = require('casbin');
    const MongooseAdapter = require('casbin-mongoose-adapter');
    
    const model = path.resolve(__dirname, './your_model.conf');
    const adapter = await MongooseAdapter.newAdapter('mongodb://your_mongodb_uri:27017');
    const enforcer = await newEnforcer(model, adapter);

    That is all what required for integrating the adapter into casbin. Casbin itself calls adapter methods to persist updates you made through it.

    Configuration

    You can pass mongooose-specific options when instantiating the adapter:

    const MongooseAdapter = require('casbin-mongoose-adapter');
    const adapter = await MongooseAdapter.newAdapter('mongodb://your_mongodb_uri:27017', { mongoose_options: 'here' });

    Additional information regard to options you can pass in you can find in mongoose documentation

    Filtered Adapter

    You can create an adapter instance that will load only those rules you need to.

    A simple case for it is when you have separate policy rules for separate domains (tenants). You do not need to load all the rules for all domains to make an authorization in specific domain.

    For such cases, filtered adapter exists in casbin.

    const MongooseAdapter = require('casbin-mongoose-adapter');
    const adapter = await MongooseAdapter.newFilteredAdapter('mongodb://your_mongodb_uri:27017');

    License

    Apache-2.0

    Install

    npm i casbin-mongoose-adapter

    DownloadsWeekly Downloads

    378

    Version

    2.2.3

    License

    Apache-2.0

    Unpacked Size

    98.8 kB

    Total Files

    26

    Last publish

    Collaborators

    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar