browserslist
TypeScript icon, indicating that this package has built-in type declarations

4.23.0 • Public • Published

Browserslist Cult Of Martians

Browserslist logo by Anton Popov

The config to share target browsers and Node.js versions between different front-end tools. It is used in:

All tools will find target browsers automatically, when you add the following to package.json:

  "browserslist": [
    "defaults and fully supports es6-module",
    "maintained node versions"
  ]

Or in .browserslistrc config:

# Browsers that we support

defaults and fully supports es6-module
maintained node versions

Developers set their version lists using queries like last 2 versions to be free from updating versions manually. Browserslist will use caniuse-lite with Can I Use data for this queries.

You can check how config works at our playground: browsersl.ist

browsersl.ist website

Sponsored by Evil Martians  Supported by Cube

Docs

Read full docs here.

Readme

Keywords

Package Sidebar

Install

npm i browserslist

Weekly Downloads

38,567,138

Version

4.23.0

License

MIT

Unpacked Size

62.8 kB

Total Files

11

Last publish

Collaborators

  • ai