browser-pdf-support

0.2.0 • Public • Published

Can I has PDF?

A tiny NPM module that determines if the browser can render PDFs, either with built-in support like Safari, Chrome and Firefox, or with Adobe Acrobat in Internet Explorer.

The module is expected to be used with the amazing browserify.

var pdfSupport = require('browser-pdf-support');

if (pdfSupport()) {
  console.log('we has PDF!');
} else {
  console.log('oh dear, you'll need to download acrobat or a real browser...');
}

Package Sidebar

Install

npm i browser-pdf-support

Weekly Downloads

267

Version

0.2.0

License

MIT

Last publish

Collaborators

  • refractalize