browser-or-node
TypeScript icon, indicating that this package has built-in type declarations

3.0.0 • Public • Published

Browser or Node.js

npm version License: MIT

Check in which environment the code is running - browser/node.js/webworker/jsdom/deno.

[!NOTE] To help release v3.0.0, please try v3.0.0-pre.0 and let us know if you run into issues.

Install

$ npm install --save browser-or-node

Usage

Import the checks and use it in your code. Works with both ESM and CJS imports.

import * as jsEnv from "browser-or-node";
// import { isBrowser, isNode, isWebWorker, isJsDom, isDeno, isBun } from "browser-or-node";
// const jsEnv = require("browser-or-node");

if (jsEnv.isBrowser) {
  // do browser only stuff
}

if (jsEnv.isNode) {
  // do node.js only stuff
}

if (jsEnv.isWebWorker) {
  // do web worker only stuff
}

if (jsEnv.isJsDom) {
  // do jsdom only stuff
}

if (jsEnv.isDeno) {
  // do deno only stuff
}

if (jsEnv.isBun) {
  // do bun only stuff
}

License

MIT © Dinesh Pandiyan

Package Sidebar

Install

npm i browser-or-node

Weekly Downloads

683,330

Version

3.0.0

License

MIT

Unpacked Size

8.35 kB

Total Files

8

Last publish

Collaborators

  • flexdinesh