Boolean expression evaluator

You need node v0.8.11 or higher, npm and make on your PATH. Now just run


The default node package in Ubuntu 12.04 is v0.6.12, so you would need to do the following additional steps:

sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs npm

Most Linux distributions come with an old Node.js version. Read the official Node.js wiki for instructions on how to install the latest package.