Notoriously Problematic Merge
    Have ideas to improve npm?Join in the discussion! »

    babel-preset-gatsby-package

    1.2.0 • Public • Published

    babel-preset-gatsby-package

    This Babel preset is used for our internal packages. If you're looking for the preset a Gatsby Site can use, please refer to babel-preset-gatsby instead.

    Packages

    Usage

    Install babel-preset-gatsby-package and add a .babelrc file with the following content to the root of your project:

    npm install --dev babel-preset-gatsby-package
    {
      "presets": ["babel-preset-gatsby-package"]
    }

    Options

    browser

    boolean, defaults to false.

    Defines if @babel/preset-env is configured to target browsers or Node.js environments.

    debug

    boolean, defaults to false.

    Outputs the targets/plugins used and the version specified in plugin data version to console.log.

    nodeVersion

    string, defaults to 10.13

    Allows the Node.js version target to be modified per @babel/preset-env documentation

    Keywords

    none

    Install

    npm i babel-preset-gatsby-package

    DownloadsWeekly Downloads

    25,449

    Version

    1.2.0

    License

    MIT

    Unpacked Size

    18 kB

    Total Files

    6

    Last publish

    Collaborators

    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar
    • avatar