Share your code. npm Orgs help your team discover, share, and reuse code. Create a free org »

babel-preset-fe

1.0.16 • Public • Published

babel-preset-fe

Changelog

[1.0.16]

  • Build-in babel-plugin-transform-runtime

[1.0.8]

  • Move up babel-plugin-transform-decorators-legacy

[1.0.5]

  • Rollback es2015-modules-commonjs(failed on old project)
  • Move up babel-plugin-transform-class-properties

[1.0.2]

[1.0.1]

  • Remove es2015-modules-commonjs(because webpack2 supports it already!)

Install

$ npm install --save-dev babel-preset-fe

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["fe"]
}

Via CLI

$ babel script.js --presets fe

Via Node API

require('babel-core').transform('code', {
  presets: ['fe']
})

Keywords

none

install

npm i babel-preset-fe

Downloadsweekly downloads

17

version

1.0.16

license

ISC

last publish

collaborators

  • avatar