Neverending Puppy Marathon
Share your code. npm Orgs help your team discover, share, and reuse code. Create a free org »

babel-preset-es6-node6

0.5.0 • Public • Published

babel-preset-es6-node6

Babel preset to make node@6 fully ES2015 compatible.

Node@6 has great ES2015 support, this module just adds missing features:

Install

npm install --save-dev babel-preset-es6-node6

Usage

Read "Configuring Babel 6" article for more information about babel@6 configuration.

Via .babelrc (recommended)

.babelrc

{
  "presets": ["es6-node6"]
}

Via CLI

babel script.js --presets es6-node6

Via Node API

require('babel-core').transform('code', {
  presets: ['es6-node6'],
})

License

MIT

install

npm i babel-preset-es6-node6

Downloadsweekly downloads

9

version

0.5.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability