Wondering what’s next for npm?Check out our public roadmap! »

babel-plugin-syntax-decorators

6.13.0 • Public • Published

babel-plugin-syntax-decorators

Allow parsing of decorators.

Installation

$ npm install babel-plugin-syntax-decorators

Usage

Via .babelrc (Recommended)

.babelrc

{
  "plugins": ["syntax-decorators"]
}

Via CLI

$ babel --plugins syntax-decorators script.js

Via Node API

require("babel-core").transform("code", {
  plugins: ["syntax-decorators"]
});

Keywords

Install

npm i babel-plugin-syntax-decorators

DownloadsWeekly Downloads

779,845

Version

6.13.0

License

MIT

Last publish

Collaborators

  • avatar
  • avatar
  • avatar
  • avatar