Notes Per Minute

    babel-plugin-remove-use-strict

    1.0.1 • Public • Published

    babel-plugin-remove-use-strict

    remove "use strict" directive

    Installation

    $ npm install babel-plugin-remove-use-strict

    Usage

    Via .babelrc (Recommended)

    .babelrc

    {
      "plugins": ["remove-use-strict"]
    }

    Via CLI

    $ babel --plugins remove-use-strict script.js

    Via Node API

    require("@babel/core").transform(`
        "use strict";
        function f(){
            "use strict"
            log("use strict")
        }
    `, {
      plugins: ["remove-use-strict"]
    });

    Install

    npm i babel-plugin-remove-use-strict

    DownloadsWeekly Downloads

    605

    Version

    1.0.1

    License

    MIT

    Unpacked Size

    3.16 kB

    Total Files

    5

    Last publish

    Collaborators

    • tswordyao