awssum-amazon-emr

AwsSum plugin for Amazon Elastic MapReduce (EMR).

NOTE: AwsSum is now deprecated. Please use aws-sdk instead.

awssum-amazon-emr

This is an AwsSum plugin!

You'll need to add awssum-amazon-emr to your package.json dependencies. Both awssum and awssum-amazon are pulled in as peer dependencies.

Describe your job flows:

var fmt = require('fmt');
var amazonEmr = require('awssum-amazon-emr.js');
 
var emr = new amazonEmr.Emr({
    'accessKeyId'     : process.env.ACCESS_KEY_ID,
    'secretAccessKey' : process.env.SECRET_ACCESS_KEY,
    'region'          : amazonEmr.US_EAST_1,
});
 
emr.DescribeJobFlows(function(err, data) {
    fmt.dump(err, 'err');
    fmt.dump(data, 'data');
});

(Ends)