Neurotic Programmer Masquerade

    autocode-puppeteer

    2.0.1 • Public • Published

    Autocode Puppeteer

    Allows use of Puppeteer in Autocode services. Combines the puppeteer-core and chrome-aws-lambda packages.

    Usage

    Certain arguments to puppeteer.launch are restricted. The package will throw an error if you attempt to pass args, executablePath, or headless as an option into the launch method.

    const puppeteer = require('autocode-puppeteer');
    
    module.exports = async (context) => {
    
      let result;
      let browser;
    
      try {
        browser = await puppeteer.launch();
        let page = await browser.newPage();
        await page.goto(context.params.url || 'https://example.com');
        result = await page.title();
        await browser.close();
      } catch (error) {
        if (!!browser) {
          await browser.close();
        }
        throw error;
      }
    
      return result;
    
    };
    

    For more usage information, see the examples in the Puppeteer repo.

    Keywords

    none

    Install

    npm i autocode-puppeteer

    DownloadsWeekly Downloads

    44

    Version

    2.0.1

    License

    MIT

    Unpacked Size

    3.79 kB

    Total Files

    4

    Last publish

    Collaborators

    • jacoblee93