at-least-node

    1.0.0 • Public • Published

    at-least-node

    npm node NPM

    Sometimes you need to check if you're on at least a given Node.js version, but you don't want to pull in the whole semver kitchen sink. That's what at-least-node is for.

    Package Size
    at-least-node 2.6 kB
    semver 75.5 kB
    const atLeastNode = require('at-least-node')
    atLeastNode('10.12.0')
    // -> true on Node 10.12.0+, false on anything below that

    When passing in a version string:

    • You cannot include a leading v (i.e. v10.12.0)
    • You cannot omit sections (i.e. 10.12)
    • You cannot use pre-releases (i.e. 1.0.0-beta)
    • There is no input validation, if you make a mistake, the resulting behavior is undefined

    Install

    npm i at-least-node

    DownloadsWeekly Downloads

    10,156,159

    Version

    1.0.0

    License

    ISC

    Unpacked Size

    2.63 kB

    Total Files

    4

    Last publish

    Collaborators

    • ryanzim