Navel Piercing Madness

    assumer

    0.2.1 • Public • Published

    assumer-js

    A JavaScript library for assuming AWS IAM roles between accounts.

    NPM

    Known Vulnerabilities

    Install

    npm install -S assumer
    

    Usage

    const assumer = require('assumer');
     
    const data = {
      controlAccount: '123456789012',
      controlRole: 'control/role',
      targetAccount: '111111111111',
      targetRole: 'target/role',
      username: 'username',
      mfaToken: '123456'
    }
    assumer(data).then(creds => console.log(creds))
    // {AccessKeyId: ASIA..., SecretAccessKey: ..., SessionToken: ...}

    TODO

    • Add tests

    Install

    npm i assumer

    DownloadsWeekly Downloads

    2

    Version

    0.2.1

    License

    Apache-2.0

    Last publish

    Collaborators

    • pmbenjamin