array-includes-with-glob
    TypeScript icon, indicating that this package has built-in type declarations

    4.0.2 • Public • Published

    array-includes-with-glob

    Like _.includes but with wildcards

    Install

    This package is ESM only: Node 12+ is needed to use it and it must be imported instead of required:

    npm i array-includes-with-glob

    If you need a legacy version which works with require, use version 3.1.0

    Quick Take

    import { strict as assert } from "assert";
    import { includesWithGlob } from "array-includes-with-glob";
    
    assert.equal(includesWithGlob(["xc", "yc", "zc"], "*c"), true);
    // (all 3)
    
    assert.equal(includesWithGlob(["xc", "yc", "zc"], "*a"), false);
    // (none found)
    
    assert.equal(includesWithGlob(["something", "anything", "zzz"], "some*"), true);
    // (1 hit)

    Documentation

    Please visit codsen.com for a full description of the API and examples.

    Contributing

    To report bugs or request features or assistance, raise an issue on GitHub.

    Licence

    MIT License

    Copyright (c) 2010-2021 Roy Revelt and other contributors

    ok codsen star

    Install

    npm i array-includes-with-glob

    DownloadsWeekly Downloads

    3,292

    Version

    4.0.2

    License

    MIT

    Unpacked Size

    17.5 kB

    Total Files

    9

    Last publish

    Collaborators

    • royston