node package manager

ajv-istanbul

ajv-istanbul

Instrument validation code generated by Ajv to measure test coverage of your schemas

Build Status npm version Gitter

Install

npm i ajv-istanbul --save-dev

Usage

ajv-istanbul requires using Ajv version >= 5.0.1-beta.

var Ajv = require('ajv');
var ajv = new Ajv;
require('ajv-istanbul')(ajv);

See tests for example how to collect coverage and generate reports.

License

MIT