This package has been deprecated

Author message:

Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.

@wp-blocks/wp-update

0.2.2 • Public • Published

@wp-blocks/update

THIS PACKAGE NAME HAS BEEN CHANGED TO wp-deps

SEE https://www.npmjs.com/package/wp-deps

What is this?

Utility to update dependencies on Gutenberg to a specific release.

When should I use this?

When developing blocks and using @wordpress scoped packages, the current versioning scheme does not make managing dependencies on Gutenberg very simple. Especially if you need to target a specific release of Gutenberg. See this discussion in the WordPress/gutenberg repo.

The @wordpress/scripts does have command packages-update, though it calls npm install, not just adjust the version numbers. This project uses pnpm and calling npm install is not ideal.

Usage

npx @wp-blocks/wp-update --target 15.1

Optionally the devDependencies of a release can be included in the update as well. The versioning of development dependencies isn't typically as large of a issue when trying to target a specific release of Gutenberg, but it is made available if necessary for your situation.

npx @wp-blocks/wp-update --target 15.1 -D

License

@wp-blocks/wp-update is free software, and is released under the terms of the GNU General Public License version 3. See LICENSE.md for complete license.

Readme

Keywords

Package Sidebar

Install

npm i @wp-blocks/wp-update

Weekly Downloads

0

Version

0.2.2

License

GPL-2.0-or-later

Unpacked Size

37.3 kB

Total Files

3

Last publish

Collaborators

  • erikyo
  • bitmachina