@wearerequired/eslint-config

    3.0.0 • Public • Published

    required JavaScript Coding Standard

    required coding standard for JavaScript, based on the rules provided by @wordpress/eslint-plugin.

    Installation

    This package is an ESLint shareable configuration and requires eslint and @wordpress/eslint-plugin to be installed. To install this config and the peerDependencies run:

    npx install-peerdeps --dev @wearerequired/eslint-config@latest

    Usage

    To opt-in to the default configuration, extend your own project's .eslintrc.js file:

    module.exports = {
    	extends: [ '@wearerequired/eslint-config' ],
    };

    a required open source product - let's get in touch

    Install

    npm i @wearerequired/eslint-config

    DownloadsWeekly Downloads

    93

    Version

    3.0.0

    License

    GPL-2.0-or-later

    Unpacked Size

    21.7 kB

    Total Files

    4

    Last publish

    Collaborators

    • grapplerulrich
    • iamrequired
    • ocean90
    • velthy
    • paschi