This package has been deprecated

Author message:

WalletConnect's v1 SDKs are now deprecated. Please upgrade to a v2 SDK. For details see: https://docs.walletconnect.com/

@walletconnect/web3-subprovider
TypeScript icon, indicating that this package has built-in type declarations

1.8.0 • Public • Published

WalletConnect Web3 Subprovider

Web3 Subprovider for WalletConnect

For more details, read the documentation

Example

import Web3 from "web3";
import ProviderEngine from "web3-provider-engine";
import WalletConnectSubprovider from "@walletconnect/web3-subprovider";

const engine = new ProviderEngine();

// Add other subproviders
engine.addProvider(...);

engine.addProvider(
  new WalletConnectSubprovider({
    bridge: "https://bridge.walletconnect.org" // Required
  })
);

engine.start();

const web3 = new Web3(engine);

Package Sidebar

Install

npm i @walletconnect/web3-subprovider

Weekly Downloads

15

Version

1.8.0

License

Apache-2.0

Unpacked Size

702 kB

Total Files

13

Last publish

Collaborators

  • cyberdrk
  • nachosan
  • huxwell
  • chris13524
  • devceline
  • gancho_walletconnect
  • bkrem
  • pedrouid