@vkontakte/eslint-config

    3.1.0 • Public • Published

    @vkontakte/eslint-config

    Правила линтинга ECMAScript, JSX и TypeScript модулей от VK.

    Установка

    yarn add @vkontakte/eslint-config или npm i @vkontakte/eslint-config

    Учтите, что помимо основого пакета, вам нужно установить его peerDependencies. Выполните команду npm info "@vkontakte/eslint-config" peerDependencies, чтобы увидеть требуемые версии зависимостей.

    Использование

    В вашем .eslintrc добавьте extends:

    // .eslintrc.js
    
    modules.exports = {
      "extends": ["@vkontakte"]
    }

    Конфиг для typescript-файлов лежит отдельно. Он подключается так же через extends:

    // .eslintrc.js
    
    modules.exports = {
      "extends": ["@vkontakte/eslint-config/typescript"]
    }

    Keywords

    none

    Install

    npm i @vkontakte/eslint-config

    DownloadsWeekly Downloads

    312

    Version

    3.1.0

    License

    MIT

    Unpacked Size

    15.1 kB

    Total Files

    14

    Last publish

    Collaborators

    • vkcom-publisher