Nozzle Piping Mismatch

    @vaporyjs/rlp

    2.0.0 • Public • Published

    SYNOPSIS

    NPM Package Build Status Coverage Status Gitter or #vaporyjs on freenode

    js-standard-style

    Recursive Length Prefix Encoding for node.js.

    INSTALL

    npm install rlp

    install with -g if you want to use the cli.

    USAGE

    var RLP = require('rlp');
    var assert = require('assert');
    
    var nestedList = [ [], [[]], [ [], [[]] ] ];
    var encoded = RLP.encode(nestedList);
    var decoded = RLP.decode(encoded);
    assert.deepEqual(nestedList, decoded);
    

    API

    rlp.encode(plain) - RLP encodes an Array, Buffer or String and returns a Buffer.

    rlp.decode(encoded, [skipRemainderCheck=false]) - Decodes an RLP encoded Buffer, Array or String and returns a Buffer or an Array of Buffers. If skipRemainderCheck is enabled, rlp will just decode the first rlp sequence in the buffer. By default, it would throw an error if there are more bytes in Buffer than used by rlp sequence.

    CLI

    rlp decode <hex string>
    rlp encode <json String>

    TESTS

    Test uses mocha. To run npm test

    CODE COVERAGE

    Install dev dependencies npm install

    Run npm run coverage

    The results are at coverage/lcov-report/index.html

    Keywords

    Install

    npm i @vaporyjs/rlp

    DownloadsWeekly Downloads

    9

    Version

    2.0.0

    License

    MPL-2.0

    Unpacked Size

    24.5 kB

    Total Files

    6

    Last publish

    Collaborators

    • marlonhanks