@ui5/webcomponents-ie11

    1.0.0-rc.15 • Public • Published

    UI5 icon

    UI5 Web Components - IE11

    DEPRECATED! UI5 Web Components do not officially support Internet Explorer 11. While this package allows the project to run on legacy browsers, future compatibility is not guaranteed. Use at your own risk!

    Travis CI Build Status npm Package Version

    Contains polyfills and adapter code for Internet Explorer 11

    This package transparently integrates Internet Explorer 11 support whenever any of these modules is imported:

    • import "@ui5/webcomponents-ie11/dist/features/IE11.js";
    • import "@ui5/webcomponents-ie11/dist/features/IE11WithWebComponentsPolyfill.js";

    Running UI5 Web Components on Internet Explorer 11

    Most modern browsers - Chrome, Firefox, Safari, Edge (Chromium-based), support Web Components natively.

    If your app needs to run on IE11, you should import:

    import "@ui5/webcomponents-ie11/dist/features/IE11.js";

    In addition, you should load the official Web Components polyfill in your index file, as described here.

    Please note that the aforementioned webcomponents-loader.js is not shipped as part of UI5 Web Components, but should be imported separately.

    Example:

    <script src="path/to/your/copy/of/webcomponents-loader.js"></script>
    <script src="path/to/your/javasacript/app.js" type="module"></script>

    As shown in the example above, it's recommended to load the Web Components Polyfill first, and the web components next.

    Finally, there is an alternative to the IE11.js import:

    import "@ui5/webcomponents-ie11/dist/features/IE11WithWebComponentsPolyfill.js";

    that includes the Web Components Polyfill too, so you don't have to import it manually.

    This may be useful in certain use cases when your app has polyfills of its own and you need to guarantee the order of execution.

    Resources

    Support

    We welcome all comments, suggestions, questions, and bug reports. Please follow our Support Guidelines on how to report an issue, or chat with us in the #webcomponents channel of the OpenUI5 Community Slack.

    Contribute

    Please check our Contribution Guidelines.

    License

    Copyright (c) 2019 SAP SE or an SAP affiliate company. All rights reserved. This file is licensed under the Apache Software License, Version 2.0 except as noted otherwise in the LICENSE file.

    Install

    npm i @ui5/webcomponents-ie11

    DownloadsWeekly Downloads

    3,005

    Version

    1.0.0-rc.15

    License

    Apache-2.0

    Unpacked Size

    346 kB

    Total Files

    81

    Last publish

    Collaborators

    • adr1ann
    • ilhan007