@typhonjs-fvtt/svelte-standard

0.1.0 • Public • Published

@typhonjs-fvtt/svelte-standard

Provides a standard Svelte component library for the TyphonJS Runtime Library (Foundry VTT version).

More information coming soon. Please refer to demo projects on setup / usage details.

Installation:

In your package.json imports and dependencies include:

{
  "imports": {
    "#runtime/*": "@typhonjs-fvtt/runtime/*",
    "#standard/*": "@typhonjs-fvtt/svelte-standard/*"
  },
  "dependencies": {
    "@typhonjs-fvtt/runtime": "^0.1.0",
    "@typhonjs-fvtt/svelte-standard": "^0.1.0",
    "svelte": "^4.0.0"
  }
}

You may use the highest released Svelte version greater than 4.0.0. It is recommended that you view the demo examples for the rest of the standard configuration details which use Vite for building your package.

API Documentation:

The initial beta release of TRL now has unified API documentation for all ESM packages available here. Work is still ongoing to provide type declarations and documentation for all of the Svelte components available in TRL.

ES Module Demo Module:

Readme

Keywords

Package Sidebar

Install

npm i @typhonjs-fvtt/svelte-standard

Weekly Downloads

52

Version

0.1.0

License

MPL-2.0

Unpacked Size

1.41 MB

Total Files

239

Last publish

Collaborators

  • typhonrt