@tinkoff/typescript-config

4.0.0 • Public • Published

@tinkoff/typescript-config

Common TypeScript configuration

Requirements

TypeScript >= 5 is required.

Usage

Install from npm

npm i --save-dev @tinkoff/typescript-config

Install tsconfig for you application type: @tsconfig/node18 for your Node.js v18 application or @tsconfig/create-react-app for CRA application.

See full lest https://github.com/tsconfig/bases.

npm i --save-dev @tsconfig/node16
# or
npm i --save-dev @tsconfig/node18
# or
npm i --save-dev @tsconfig/create-react-app

Create tsconfig.json at the project root

{
  "extends": ["@tinkoff/typescript-config/tsconfig.base", "@tsconfig/node18/tsconfig"]
}

Readme

Keywords

Package Sidebar

Install

npm i @tinkoff/typescript-config

Weekly Downloads

13

Version

4.0.0

License

Apache-2.0

Unpacked Size

13.2 kB

Total Files

7

Last publish

Collaborators

  • yeahga
  • sradyukov
  • hondasmx
  • makar_l
  • tinkoffbank
  • dmitry-korolev
  • rouland
  • ishivan
  • ytsareva
  • shoom3301
  • waterplea
  • meskill
  • marsibarsi
  • zig-green
  • super_oleg
  • dersizes
  • alexkvak