@thi.ng/geom-clip-poly
TypeScript icon, indicating that this package has built-in type declarations

2.1.131 • Public • Published

@thi.ng/geom-clip-poly

npm version npm downloads Mastodon Follow

[!NOTE] This is one of 192 standalone projects, maintained as part of the @thi.ng/umbrella monorepo and anti-framework.

🚀 Please help me to work full-time on these projects by sponsoring me on GitHub. Thank you! ❤️

About

2D polygon clipping / offsetting (Sutherland-Hodgeman, Grainer-Hormann). This is a support package for @thi.ng/geom.

Current implementations are based on toxiclibs (Java) and Clojure versions thi.ng/geom-clj.

Status

STABLE - used in production

Search or submit any issues for this package

Related packages

Installation

yarn add @thi.ng/geom-clip-poly

ESM import:

import * as gcp from "@thi.ng/geom-clip-poly";

Browser ESM import:

<script type="module" src="https://esm.run/@thi.ng/geom-clip-poly"></script>

JSDelivr documentation

For Node.js REPL:

const gcp = await import("@thi.ng/geom-clip-poly");

Package sizes (brotli'd, pre-treeshake): ESM: 317 bytes

Dependencies

API

Generated API docs

TODO

Authors

If this project contributes to an academic publication, please cite it as:

@misc{thing-geom-clip-poly,
  title = "@thi.ng/geom-clip-poly",
  author = "Karsten Schmidt",
  note = "https://thi.ng/geom-clip-poly",
  year = 2013
}

License

© 2013 - 2024 Karsten Schmidt // Apache License 2.0

Package Sidebar

Install

npm i @thi.ng/geom-clip-poly

Weekly Downloads

98

Version

2.1.131

License

Apache-2.0

Unpacked Size

22.5 kB

Total Files

6

Last publish

Collaborators

  • thi.ng