Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

@thi.ng/errors

1.0.3 • Public • Published

@thi.ng/errors

npm version npm downloads Twitter Follow

This project is part of the @thi.ng/umbrella monorepo.

About

Custom error types and helper fns used by many packages in this repo.

This feature was previously part of the @thi.ng/api package.

Installation

yarn add @thi.ng/errors

Dependencies

None

Usage examples

import * as err from "@thi.ng/errors";
 
err.illegalArity(3)
// Error: illegal arity: 3
 
err.illegalArgs("expected foo");
// Error: illegal argument(s): expected foo
 
err.illegalState("oops");
// Error: illegal state: oops
 
err.unsupported("TODO not yet implemented")
// Error: unsupported operation: TODO not yet implemented

Authors

  • Karsten Schmidt

License

© 2018 Karsten Schmidt // Apache Software License 2.0

install

npm i @thi.ng/errors

Downloadsweekly downloads

1,682

version

1.0.3

license

Apache-2.0

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability