This package has been deprecated

    Author message:

    Package no longer maintained. Please use latest version of telus-standard (https://github.com/telus/telus-standard)

    @telus/eslint-config

    2.0.1 • Public • Published

    ESLint Config

    version Build Status

    TELUS Flavour ESLint config.
    We inherit from the excellent Airbnb ESLint config and introduce some more strict requirements.

    Usage

    1. add to .eslintrc

    {
      "extends": "@telus/eslint-config"
    }

    2. install

    npm install eslint @telus/eslint-config
    npx install-group peer --package @telus/eslint-config --no-save

    3. run!

    cli
    npx eslint .
    git hooks
    echo -e '#!/bin/bash\nnpx eslint .' > .git/hooks/pre-commit && chmod +x .git/hooks/pre-commit
    editors

    editors with built-in eslint features, (e.g. Visual Studio Code) usually depend on globally installed packages


    Github: @telus • Twitter: @telusdigital

    Install

    npm i @telus/eslint-config

    DownloadsWeekly Downloads

    2,156

    Version

    2.0.1

    License

    MIT

    Unpacked Size

    5.03 kB

    Total Files

    4

    Last publish

    Collaborators

    • qwerty22
    • kamelia.yousofi
    • dltq_digital_prod_support
    • cjchoi
    • claude.grondin
    • rtong
    • robfe11
    • pdufault
    • skalfyfan
    • telusdigitaldelivery
    • sebastsavard
    • stv-telus
    • aaronfagan
    • jromanica
    • krisbnelson
    • kdmurray-t
    • t931900
    • laynegeck
    • jraff