Narcissistic Piano Mover

    @swarmion/eslint-plugin
    TypeScript icon, indicating that this package has built-in type declarations

    0.9.5 • Public • Published

    @swarmion/eslint-plugin

    An eslint plugin with rules to enforces proper usage of contracts.

    This package is part of the Swarmion project. See its documentation for more insights.

    Installation

    npm install --save-dev @swarmion/eslint-plugin

    or if using yarn

    yarn add --dev @swarmion/eslint-plugin

    Usage

    Add @swarmion to the plugins section of your .eslintrc configuration file, then configure the rules you want to use under the rules section.

    {
      "plugins": ["@swarmion"],
      "rules": {
        "@swarmion/rule-name": "error"
      }
    }

    You can also enable all the recommended rules for our plugin. Add plugin:@swarmion/recommended in extends:

    {
      "extends": ["plugin:@swarmion/recommended"]
    }

    Rules

    Key: = recommended, 🔧 = fixable

    Name Description 🔧
    @swarmion/no-undeclared-contracts Require that used contracts are defined in the serverless service file

    Install

    npm i @swarmion/eslint-plugin

    DownloadsWeekly Downloads

    38

    Version

    0.9.5

    License

    MIT

    Unpacked Size

    42.8 kB

    Total Files

    22

    Last publish

    Collaborators

    • adriencaccia
    • fargito