This package has been deprecated

Author message:

Use the original unforked package instead: postcss-markdown

@stylelint/postcss-markdown

0.36.2 • Public • Published

PostCSS Markdown Syntax

NPM version Build Status

PostCSS Syntax for parsing Markdown

Getting Started

First thing's first, install the module:

npm install postcss-syntax postcss-markdown --save-dev

If you want support SCSS/SASS/LESS/SugarSS syntax, you need to install the corresponding module.

Use Cases

var syntax = require("postcss-syntax")({
  // Enable support for HTML (default: true) See: https://github.com/gucong3000/postcss-html
  htmlInMd: true,
  // syntax for parse scss (non-required options)
  scss: require("postcss-scss"),
  // syntax for parse less (non-required options)
  less: require("postcss-less"),
  // syntax for parse css blocks (non-required options)
  css: require("postcss-safe-parser")
});
var autoprefixer = require("autoprefixer");
postcss([autoprefixer])
  .process(source, { syntax: syntax })
  .then(function(result) {
    // An alias for the result.css property. Use it with syntaxes that generate non-CSS output.
    result.content;
  });

input:

# title

```css
::placeholder {
	color: gray;
}
```

output:

# title

```css
::-webkit-input-placeholder {
	color: gray;
}
:-ms-input-placeholder {
	color: gray;
}
::-ms-input-placeholder {
	color: gray;
}
::placeholder {
	color: gray;
}
```

If you want support SCSS/SASS/LESS/SugarSS syntax, you need to install these module:

Advanced Use Cases

See: postcss-syntax

Style Transformations

The main use case of this plugin is apply PostCSS transformations to CSS (and CSS-like) code blocks in markdown file.

Package Sidebar

Install

npm i @stylelint/postcss-markdown

Weekly Downloads

732,708

Version

0.36.2

License

MIT

Unpacked Size

6.67 kB

Total Files

6

Last publish

Collaborators

  • hudochenkov
  • jeddy3
  • ntwb
  • ota-meshi
  • ybiquitous