Nine Project Managers

    @stdlib/constants-float64-max-base2-exponent
    TypeScript icon, indicating that this package has built-in type declarations

    0.0.7 • Public • Published

    Maximum Base 2 Exponent

    NPM version Build Status Coverage Status

    The maximum biased base 2 exponent for a double-precision floating-point number.

    Installation

    npm install @stdlib/constants-float64-max-base2-exponent

    Usage

    var FLOAT64_MAX_BASE2_EXPONENT = require( '@stdlib/constants-float64-max-base2-exponent' );

    FLOAT64_MAX_BASE2_EXPONENT

    The maximum biased base 2 exponent for a double-precision floating-point number.

    var bool = ( FLOAT64_MAX_BASE2_EXPONENT === 1023 );
    // returns true

    Examples

    var FLOAT64_MAX_BASE2_EXPONENT = require( '@stdlib/constants-float64-max-base2-exponent' );
    
    console.log( FLOAT64_MAX_BASE2_EXPONENT );
    // => 1023

    See Also


    Notice

    This package is part of stdlib, a standard library for JavaScript and Node.js, with an emphasis on numerical and scientific computing. The library provides a collection of robust, high performance libraries for mathematics, statistics, streams, utilities, and more.

    For more information on the project, filing bug reports and feature requests, and guidance on how to develop stdlib, see the main project repository.

    Community

    Chat


    License

    See LICENSE.

    Copyright

    Copyright © 2016-2022. The Stdlib Authors.

    Install

    npm i @stdlib/constants-float64-max-base2-exponent

    Homepage

    stdlib.io

    DownloadsWeekly Downloads

    100,741

    Version

    0.0.7

    License

    Apache-2.0

    Unpacked Size

    35 kB

    Total Files

    8

    Last publish

    Collaborators

    • stdlib-bot
    • kgryte
    • planeshifter
    • rreusser