@skyscanner/bpk-scope-migration

1.1.5 • Public • Published

bpk-scope-migration

npm version

Renames dependencies related to Backpack to use scoped packages. Works on dependencies, devDependencies and peerDependencies.

Example

Before

{
    "name": "my-package",
    "version": "1.0.0",
    "dependencies": {
        "bpk-component-button": "^1.2.3",
        "bpk-component-switch": "4.5.6",
        "lodash": "^7.8.9"
    }
}

After

{
    "name": "my-package",
    "version": "1.0.0",
    "dependencies": {
        "@skyscanner/bpk-component-button": "^1.2.3",
        "@skyscanner/bpk-component-switch": "4.5.6",
        "lodash": "^7.8.9"
    }
}

Usage

In the folder where your package.json is stored:

npx @skyscanner/bpk-scope-migration

Readme

Keywords

none

Package Sidebar

Install

npm i @skyscanner/bpk-scope-migration

Weekly Downloads

3

Version

1.1.5

License

ISC

Unpacked Size

7.25 kB

Total Files

9

Last publish

Collaborators

  • mungodewar
  • anambl
  • skyscanner-koalasquad
  • gert-jan.vercauteren
  • frugoman
  • marianeumayer-skyscanner
  • ojcurt