@simplewebauthn/browser
    TypeScript icon, indicating that this package has built-in type declarations

    4.1.0 • Public • Published

    @simplewebauthn/browser

    WebAuthn npm (scoped) Browser Support

    Installation

    This package is available on npm:

    npm install @simplewebauthn/browser

    UMD

    This package can also be installed via unpkg by including the following script in your page's <head> element. The library's methods will be available on the global SimpleWebAuthnBrowser object.

    NOTE: The only difference between the two packages below is that the ES5 bundle includes TypeScript's tslib runtime code. This adds some bundle size overhead, but does enable use of supportsWebAuthn() in older browsers to show appropriate UI when WebAuthn is unavailable.

    ES5

    If you need to support WebAuthn feature detection in deprecated browsers like IE11 and Edge Legacy, include the ES5 version:

    <script src="https://unpkg.com/@simplewebauthn/browser/dist/bundle/index.es5.umd.min.js"></script>

    ES2018

    If you only need to support modern browsers, include the ES2018 version:

    <script src="https://unpkg.com/@simplewebauthn/browser"></script>

    Usage

    You can find in-depth documentation on this package here: https://simplewebauthn.dev/docs/packages/browser

    Install

    npm i @simplewebauthn/browser

    DownloadsWeekly Downloads

    1,338

    Version

    4.1.0

    License

    MIT

    Unpacked Size

    18.4 kB

    Total Files

    17

    Last publish

    Collaborators

    • iamkale