Nondigestible Purple Mayonnaise

    @side/eslint-config-react

    0.16.0 • Public • Published

    @side/eslint-config-react

    An ESLint configuration which extends the following:

    Installation

    Install this package, and ensure to have installed its peer dependencies.

    yarn info @side/eslint-config-react peerDependencies

    yarn add -D @side/eslint-config-react

    Usage

    Once all peer dependencies have been added to your project, extend this configuration in your project's .eslintrc.js.

    .eslintrc.js

    module.exports = {
      extends: ['@side/react'],
    };

    @side/eslint-config-react/hooks

    This entry point enables the linting rules for React hooks (requires v16.8+). To use, add the following to your .eslintrc.js file:

    .eslintrc.js

    module.exports = {
      extends: ['@side/react', '@side/react/hooks],
    };

    NOTE: If you are using Create React App (CRA), this is not needed since they provide that for you already.

    Resources

    For more information on configuring ESLint, please refer to their documentation

    Keywords

    none

    Install

    npm i @side/eslint-config-react

    DownloadsWeekly Downloads

    2,164

    Version

    0.16.0

    License

    UNLICENSED

    Unpacked Size

    5.24 kB

    Total Files

    7

    Last publish

    Collaborators

    • reside-eng