Noisy Pillaging Monster

    @seikho/samlify
    TypeScript icon, indicating that this package has built-in type declarations

    2.2.1 • Public • Published

    samlify · Build Status npm version Coverage Status

    Node.js API for Single Sign On (SAML 2.0)

    Welcome PRs

    Welcome all PRs for maintaining this project, or provide a link to the repositories especially for use cases alongside with different frameworks.

    Description

    This module provides high-level API for scalable Single Sign On (SSO) implementation. Developers can easily configure the Service Providers and Identity Providers by importing the corresponding metadata. SAML2.0 provides a standard guide but leaves a lot of options, so we provide a simple interface that's highly configurable.

    Installation

    To install the stable version

    $ npm install samlify --save
    $ yarn add samlify

    Development

    This project is now developed using TypeScript 2.0, also support Yarn which is a new package manager.

    $ npm install typescript -g
    $ yarn

    Integrations

    Get Started

    const saml = require('samlify');

    See full documentation here

    Demo

    In progress

    Talks

    An introduction to Single Sign On

    License

    MIT

    Copyright

    Copyright (C) 2016-2017 Tony Ngan, released under the MIT License.

    Install

    npm i @seikho/samlify

    DownloadsWeekly Downloads

    3

    Version

    2.2.1

    License

    MIT

    Last publish

    Collaborators

    • seikho