node package manager
Loosely couple your services. Use Orgs to version and reuse your code. Create a free org »

@sailshq/lodash

@sailshq/lodash

A fork of Lodash 3.10.x with ongoing maintenance from the Sails core team.

This repo will only be updated when there are immediate, material issues affecting expected usage, like this one. Our goal is to diverge as little as possible, and to encourage the use of Lodash 4 and above whenever possible. This repo is really just for us, and anyone else who really likes Lodash 3 exactly the way it is.

In other words, there will never be any new methods or options added to Lodash on this fork, and consequently there will be no minor version or major version bumps from this fork-- only patches.

Sails <=v0.12 users:

This is the version of Lodash exposed as a default global (_) in Sails apps prior to Sails v1.0.

...but Sails v1.0 changes that.

If your app is using Sails v1.0 or above, or if you are on <=0.12, but are not using the Lodash global, then you needn't worry about this package-- it is used interally in Sails, but does not touch userland code in your application. Click here to learn about how the Lodash global works in Sails v1.0.

On the other hand, if your app is using Sails <=0.12 and you are using the Lodash global:

  • Click here for usage docs
  • Click here to see how to disable that global and use your own version of Lodash.

Bugs   NPM version

To report a bug, click here.

Contributing

Please observe the guidelines and conventions laid out in the Sails project contribution guide when opening issues or submitting pull requests.

NPM

License

Lodash license

Lodash is free and open source under the MIT License.

All ad hoc additions in this repo are also MIT-licensed.

Sails framework license

The Sails framework is free and open-source under the MIT License.