@rocicorp/eslint-config

0.5.1 • Public • Published

Shared eslint config for Rocicorp Projects

The package includes all the dependencies to have a working eslint setup that works with the configuration. Adopting projects will only need to install @rocicorp/eslint-config.

Install

$ npm install @rocicorp/eslint-config --save-dev

Usage

** Make sure you have a tsconfig.json and .eslintignore in your project **

Add this to the package.json:

{
  "eslintConfig": {
    "extends": "@rocicorp/eslint-config"
  }
}

Readme

Keywords

none

Package Sidebar

Install

npm i @rocicorp/eslint-config

Weekly Downloads

60

Version

0.5.1

License

Apache 2.0

Unpacked Size

4.49 kB

Total Files

4

Last publish

Collaborators

  • alexhking
  • darick
  • cesaraz1
  • grgbkr
  • aboodman
  • arv