@quantnetwork/overledger-dlt-ethereum
TypeScript icon, indicating that this package has built-in type declarations

2.4.1 • Public • Published

@quantnetwork/overledger-dlt-ethereum

Overledger SDK module for interaction with the Ethereum distributed ledger technology.

Installation

Install using npm:

npm install @quantnetwork/overledger-dlt-ethereum

Or, if you prefer using yarn:

yarn add @quantnetwork/overledger-dlt-ethereum

API Reference

Modules

overledger-dlt-ethereum

Classes

Ethereum

overledger-dlt-ethereum

overledger-dlt-ethereum.default

Development package for Ethereum.

overledger-dlt-ethereum.log

Ethereum

new Ethereum(sdk)

Param Type Description
sdk any the sdk instance

ethereum.name

Name of the DLT

ethereum.symbol

Symbol of the DLT

ethereum.createAccount()

Create an Ethereum account

Returns: Account - the new Ethereum account

ethereum.setAccount(accountInfo)

Param Type Description
accountInfo Account The standardised account information

Set an account for signing transactions for a specific DLT

Readme

Keywords

none

Package Sidebar

Install

npm i @quantnetwork/overledger-dlt-ethereum

Weekly Downloads

1

Version

2.4.1

License

Apache-2.0

Unpacked Size

105 kB

Total Files

20

Last publish

Collaborators

  • alexchiriac
  • gverdian
  • luker501
  • jvaralves