This package has been deprecated

Author message:

This package has been deprecated. Please update to the new @brightlayer-ui/prettier-config.

@pxblue/prettier-config

1.0.3 • Public • Published

PX Blue Prettier Configuration

This package contains the PXBlue prettier and editorconfig profiles used to enforce consistent code style.

Installation

From the root of your project, install prettier:

yarn add --dev prettier

and the PX Blue prettier config:

yarn add --dev @pxblue/prettier-config

Configuration

Add the following script to your package.json.

"prettier": "@pxblue/prettier-config",
"scripts": {
    "prettier": "prettier \"src/**/**.{ts,tsx,js,jsx,json,css,scss,html}\" --write",
}

The --write flag will automatically fix all code style violations.

You can update the file extensions list to suit the particular files you would like to format.

Usage

To format the files in your project, run yarn prettier.

Package Sidebar

Install

npm i @pxblue/prettier-config

Weekly Downloads

15

Version

1.0.3

License

BSD-3-Clause

Unpacked Size

4.22 kB

Total Files

6

Last publish

Collaborators

  • px-blue