@pulumiverse/exoscale
TypeScript icon, indicating that this package has built-in type declarations

0.59.0 • Public • Published

Exoscale Resource Provider

The Exoscale Resource Provider lets you manage Exoscale resources.

Installing

This package is available for several languages/platforms:

Node.js (JavaScript/TypeScript)

To use from JavaScript or TypeScript in Node.js, install using either npm:

npm install @pulumiverse/exoscale

or yarn:

yarn add @pulumiverse/exoscale

Python

To use from Python, install using pip:

pip install pulumiverse_exoscale

Go

To use from Go, use go get to grab the latest version of the library:

go get github.com/pulumiverse/pulumi-exoscale/sdk/go/...

.NET

To use from .NET, install using dotnet add package:

dotnet add package Pulumiverse.Exoscale

Configuration

The following configuration points are available for the exoscale provider:

  • exoscale:key (environment: EXOSCALE_API_KEY) - Exoscale account API key
  • exoscale:secret (environment: EXOSCALE_API_SECRET) - Exoscale account API secret
  • exoscale:timeout - Global async operations waiting time in seconds (default: 300)

Reference

For detailed reference documentation, please visit the Pulumi registry.

Package Sidebar

Install

npm i @pulumiverse/exoscale

Weekly Downloads

12

Version

0.59.0

License

Apache-2.0

Unpacked Size

592 kB

Total Files

166

Last publish

Collaborators

  • stevemorgandev
  • pulumiverse-bot
  • ringods