@pinknetworkx/error-overlay-webpack-plugin

2.0.0 • Public • Published

Error Overlay Webpack Plugin

Node.js CI

Catch errors with style 💥

This plugin will display an error overlay in your application. It is the same error overlay used in create-react-app.

  • 📦 Webpack 5 support
  • 🥞 Elegant stack trace
  • 📝 Click to open error line in editor

Error Overlay Webpack Plugin Example

npm install error-overlay-webpack-plugin --save-dev

Usage

// webpack.config.js
const ErrorOverlayPlugin = require('error-overlay-webpack-plugin')

module.exports = {
  entry: 'main.js',
  output: {
    path: __dirname + '/dist',
    filename: 'bundle.js',
  },
  plugins: [new ErrorOverlayPlugin()],
  devtool: 'cheap-module-source-map', // 'eval' is not supported by error-overlay-webpack-plugin
}

License

MIT

Install

DownloadsWeekly Downloads

0

Version

2.0.0

License

MIT

Unpacked Size

16.5 kB

Total Files

14

Last publish

Collaborators

  • alexsotocx
  • luiza.dias
  • jona_wilmsmann
  • fabian-pink
  • davidpink
  • pinkgg
  • zimmcognito