Nocturnally Psychologizing Millipede

    @passport-next/passport

    3.1.0 • Public • Published

    Passport-Next/Passport

    Status: NPM version Build Status Coverage Status Maintainability Dependencies SAST

    About

    Passport-Next/Passport is Express-compatible authentication middleware for Node.js.

    Passport's sole purpose is to authenticate requests, which it does through an extensible set of plugins known as strategies. Passport does not mount routes or assume any particular database schema, which maximizes flexibility and allows application-level decisions to be made by the developer. The API is simple: you provide Passport a request to authenticate, and Passport provides hooks for controlling what occurs when authentication succeeds or fails.

    Install

    $ npm install @passport-next/passport
    

    Docs

    Please see the wiki

    Need help?

    Please raise an issue and/or ask a question on Stackoverflow with the passport.js tag.

    Support policy

    We support all node versions supported by the Node Foundation

    Contributing

    Please see CONTRIBUTING.md

    Install

    npm i @passport-next/passport

    DownloadsWeekly Downloads

    801

    Version

    3.1.0

    License

    MIT

    Unpacked Size

    124 kB

    Total Files

    30

    Last publish

    Collaborators

    • brettz9
    • rwky
    • adamhathcock
    • guyellis