This package has been deprecated

Author message:

Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.

@mediamonks/eslint-config-base

2.2.1 • Public • Published

@mediamonks/eslint-config-base npm version

This package provides a Base TypeScript eslint configuration as an extensible shared config, based on the MediaMonks Coding Standards.

Installation

The configuration has a number of peer dependencies that must be installed.

npm i --dev @mediamonks/eslint-config-base

Note for yarn users: yarn does not install peer dependencies by default, this can be supplemented with install-peerdeps.

npx install-peerdeps --dev @mediamonks/eslint-config-base

Usage

Now you can add @mediamonks/eslint-config-base to your .eslintrc. Adding parserOptions.project is only required if your project is using TypeScript.

{
  "extends": "@mediamonks/eslint-config-base",
  "parserOptions": {
    "project": "./tsconfig.json" // can also be an array, if multiple `tsconfig.json` are present
  }
}

Formatting & Prettier

This eslint configuration purposely had its formatting rules disabled. We encourage to use prettier for formatting using the @mediamonks/prettier-config.

Package Sidebar

Install

npm i @mediamonks/eslint-config-base

Weekly Downloads

48

Version

2.2.1

License

MIT

Unpacked Size

9.28 kB

Total Files

3

Last publish

Collaborators

  • will-newton
  • jessel
  • twan.braas
  • leroykorterink
  • mientjan
  • devmonk
  • thanarie
  • nathanuphoff
  • larsvanbraam