Notary Public Mystifier

    @loopback/eslint-config

    13.0.7 • Public • Published

    @loopback/eslint-config

    Shared ESLint config to enforce a consistent code style for LoopBack development

    Installation

    npm install --save @loopback/eslint-config
    
    npm install --save-dev \
    eslint \
    @typescript-eslint/eslint-plugin \
    @typescript-eslint/parser \
    eslint-config-prettier \
    eslint-plugin-eslint-plugin \
    eslint-plugin-mocha

    Basic Use

    Add .eslintrc.json file to your project, for example:

    {
      "extends": "@loopback/eslint-config"
    }

    NOTE:

    Due to the limitation of how ESLint plugins are loaded, the peerDependencies of this module should be added to devDependencies of your package.json.

    Contributions

    Contributors

    See all contributors.

    License

    MIT

    Keywords

    none

    Install

    npm i @loopback/eslint-config

    DownloadsWeekly Downloads

    24,229

    Version

    13.0.7

    License

    MIT

    Unpacked Size

    34.9 kB

    Total Files

    5

    Last publish

    Collaborators

    • rfeng
    • bajtos
    • rmg
    • hacksparrow
    • dhmlau
    • jerry-apic
    • theprez
    • frbuceta
    • marioestradarosa
    • achrinza