Nomadic People Migration

    @laser-dac/ether-dream
    TypeScript icon, indicating that this package has built-in type declarations

    0.4.2 • Public • Published

    @laser-dac/ether-dream

    This package makes Laser DAC compatible with the Ether Dream. Should work on all operating systems.

    This package is originally based on node-etherdream but with many changes.

    yarn add @laser-dac/ether-dream
    npm i @laser-dac/ether-dream
    

    Usage

    import { DAC } from '@laser-dac/core';
    import { EtherDream } from '@laser-dac/ether-dream';
    
    const dac = new DAC();
    dac.use(new EtherDream());
    const started = await dac.start();
    if (started) {
      const pps = 30000; // points per second
      // draw a horizontal red line from left to right in the center
      // @laser-dac/draw can help you with drawing points!
      const scene = {
        points: [
          { x: 0.1, y: 0.5, r: 1, g: 0, b: 0 },
          { x: 0.9, y: 0.5, r: 1, g: 0, b: 0 },
        ],
      };
      dac.stream(scene, pps);
    }

    See for more usage info and examples the Laser DAC project on GitHub.

    Install

    npm i @laser-dac/ether-dream

    DownloadsWeekly Downloads

    1

    Version

    0.4.2

    License

    MIT

    Unpacked Size

    24.2 kB

    Total Files

    12

    Last publish

    Collaborators

    • spacek33z
    • rutgerschimmel