This package has been deprecated

    Author message:

    This package is now deprecated. See https://instructure.design/#v7-upgrade-guide for instructions on upgrading to version 7.0

    @instructure/ui-a11y
    TypeScript icon, indicating that this package has built-in type declarations

    6.27.0 • Public • Published

    category: packages

    ui-a11y

    npm  build-status  MIT License  Code of Conduct

    Deprecated Components

    The ui-a11y package contains will be removed in v7.0.0. Please update your imports as follows:

    Deprecated Utilities

    Installation

    yarn add @instructure/ui-a11y

    Usage

    import React from 'react'
    import { Dialog } from '@instructure/ui-a11y'
     
    const MyAccessibleContent = () => {
      return (
        <AccessibleContent alt="Alternative text for a screenreader only">
            Presentational content goes here
        </AccessibleContent>
      )
    }

    Keywords

    none

    Install

    npm i @instructure/ui-a11y

    DownloadsWeekly Downloads

    1,720

    Version

    6.27.0

    License

    MIT

    Unpacked Size

    203 kB

    Total Files

    49

    Last publish

    Collaborators

    • kyler-instructure
    • jonscheiding
    • instuici
    • codequistador
    • natearmstrong
    • eschiebel
    • maths22
    • hyan
    • jcrystal
    • skacsmark
    • itadmins
    • quizzesuici
    • instructure-toolsmiths-service-user
    • prenner
    • aogata-inst
    • acallejas
    • viktor.ohad
    • eszter.szabo
    • amireh-inst
    • daniel.hatas.instructure
    • brianlwatson
    • instout