Negligible Participation Metric

npm

npm’s 2019 JavaScript ecosystem survey analysis is now available! Get your copy here »

@hapiness/biim

1.4.0 • Public • Published
Hapiness

Biim

Error module based on boom.

Table of contents

Using config module

yarn or npm it in your package.json

$ npm install --save @hapiness/biim
 
or
 
$ yarn add @hapiness/biim
"dependencies": {
    "@hapiness/biim": "^1.4.0",
    //...
}
//...

Use

Node.js Script:

import { Biim } from '@hapiness/biim';
 
Biim.badRequest('my-message', 'some-data', { key: 'bad-request' });

Back to top

Change History

  • v1.4.0 (2017-11-20)
    • Latest packages' versions.
    • Documentation.
    • Change packaging process.
  • v1.3.2
    • Add module to have a lifecycle to format error message
    • Latest packages' versions
  • v1.2.0
    • Support of Boom v6.0.0
    • Latest packages' versions
  • v1.1.0
    • Improve error instantiation.
    • Update unit tests.
  • v1.0.0
    • Final release version.
  • v1.0.0-rc.6 (2017-07-16)
    • Init the project.

Back to top

Maintainers

tadaweb
Julien Fauville Antoine Gomez Sébastien Ritz Nicolas Jessel

Back to top

License

Copyright (c) 2017 Hapiness Licensed under the MIT license.

Back to top

install

npm i @hapiness/biim

Downloadsweekly downloads

6

version

1.4.0

license

SEE LICENSE IN https://github.com/hapinessjs/error/blob/master/LICENSE.md

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability